Skip to content

Commit b3045c7

Browse files
committed
adds sample rule with mitre attack threats property
1 parent 3466317 commit b3045c7

1 file changed

Lines changed: 43 additions & 0 deletions

File tree

Lines changed: 43 additions & 0 deletions
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,43 @@
1+
{
2+
"rule_id": "rule-1",
3+
"description": "Detecting root and admin users",
4+
"index": ["auditbeat-*", "filebeat-*", "packetbeat-*", "winlogbeat-*"],
5+
"interval": "5s",
6+
"name": "Detect Root/Admin Users",
7+
"severity": "high",
8+
"risk_score": 1,
9+
"type": "query",
10+
"from": "now-6s",
11+
"to": "now",
12+
"query": "user.name: root or user.name: admin",
13+
"language": "kuery",
14+
"references": ["http://www.example.com", "https://ww.example.com"],
15+
"threats": [
16+
{
17+
"framework": "MITRE ATT&CK",
18+
"tactic": {
19+
"id": "TA0040",
20+
"name": "impact",
21+
"reference": "https://attack.mitre.org/tactics/TA0040/"
22+
},
23+
"technique": {
24+
"id": "T1499",
25+
"name": "endpoint denial of service",
26+
"reference": "https://attack.mitre.org/techniques/T1499/"
27+
}
28+
},
29+
{
30+
"framework": "MITRE ATT&CK",
31+
"tactic": {
32+
"id": "T1020",
33+
"name": "Automated Exfiltration",
34+
"reference": "https://attack.mitre.org/techniques/T1020/"
35+
},
36+
"technique": {
37+
"id": "T1002",
38+
"name": "Data Compressed",
39+
"reference": "https://attack.mitre.org/techniques/T1002/"
40+
}
41+
}
42+
]
43+
}

0 commit comments

Comments
 (0)