Skip to content

Commit 8f71fa9

Browse files
committed
[Detection Rules] Add 7.15 rules
1 parent 1466099 commit 8f71fa9

9 files changed

Lines changed: 14 additions & 87 deletions

x-pack/plugins/security_solution/server/lib/detection_engine/rules/prepackaged_rules/defense_evasion_privacy_controls_tcc_database_modification.json

Lines changed: 2 additions & 2 deletions
Original file line numberDiff line numberDiff line change
@@ -14,7 +14,7 @@
1414
"query": "process where event.type in (\"start\", \"process_started\") and process.name : \"sqlite*\" and \n process.args : \"/*/Application Support/com.apple.TCC/TCC.db\"\n",
1515
"references": [
1616
"https://applehelpwriter.com/2016/08/29/discovering-how-dropbox-hacks-your-mac/",
17-
"https://github.com/bp88/JSS-Scripts/blob/master/TCC.db Modifier.sh",
17+
"https://github.com/bp88/JSS-Scripts/blob/master/TCC.db%20Modifier.sh",
1818
"https://medium.com/@mattshockl/cve-2020-9934-bypassing-the-os-x-transparency-consent-and-control-tcc-framework-for-4e14806f1de8"
1919
],
2020
"risk_score": 47,
@@ -53,5 +53,5 @@
5353
],
5454
"timestamp_override": "event.ingested",
5555
"type": "eql",
56-
"version": 1
56+
"version": 2
5757
}

x-pack/plugins/security_solution/server/lib/detection_engine/rules/prepackaged_rules/elastic_endpoint_security.json

Lines changed: 2 additions & 2 deletions
Original file line numberDiff line numberDiff line change
@@ -20,7 +20,7 @@
2020
"license": "Elastic License v2",
2121
"max_signals": 10000,
2222
"name": "Endpoint Security",
23-
"query": "event.kind:alert and event.module:(endpoint and not endgame) and not event.code: behavior\n",
23+
"query": "event.kind:alert and event.module:(endpoint and not endgame)\n",
2424
"risk_score": 47,
2525
"risk_score_mapping": [
2626
{
@@ -64,5 +64,5 @@
6464
],
6565
"timestamp_override": "event.ingested",
6666
"type": "query",
67-
"version": 4
67+
"version": 3
6868
}

x-pack/plugins/security_solution/server/lib/detection_engine/rules/prepackaged_rules/elastic_endpoint_security_behavior_protection.json

Lines changed: 0 additions & 68 deletions
This file was deleted.

x-pack/plugins/security_solution/server/lib/detection_engine/rules/prepackaged_rules/index.ts

Lines changed: 1 addition & 3 deletions
Original file line numberDiff line numberDiff line change
@@ -580,8 +580,7 @@ import rule567 from './defense_evasion_parent_process_pid_spoofing.json';
580580
import rule568 from './defense_evasion_defender_exclusion_via_powershell.json';
581581
import rule569 from './defense_evasion_whitespace_padding_in_command_line.json';
582582
import rule570 from './persistence_webshell_detection.json';
583-
import rule571 from './elastic_endpoint_security_behavior_protection.json';
584-
import rule572 from './persistence_via_bits_job_notify_command.json';
583+
import rule571 from './persistence_via_bits_job_notify_command.json';
585584

586585
export const rawRules = [
587586
rule1,
@@ -1155,5 +1154,4 @@ export const rawRules = [
11551154
rule569,
11561155
rule570,
11571156
rule571,
1158-
rule572,
11591157
];

x-pack/plugins/security_solution/server/lib/detection_engine/rules/prepackaged_rules/initial_access_azure_active_directory_high_risk_signin.json

Lines changed: 2 additions & 2 deletions
Original file line numberDiff line numberDiff line change
@@ -13,7 +13,7 @@
1313
"license": "Elastic License v2",
1414
"name": "Azure Active Directory High Risk Sign-in",
1515
"note": "## Config\n\nThe Azure Fleet integration, Filebeat module, or similarly structured data is required to be compatible with this rule.",
16-
"query": "event.dataset:azure.signinlogs and\n azure.signinlogs.properties.risk_level_during_signin:high and\n event.outcome:(success or Success)\n",
16+
"query": "event.dataset:azure.signinlogs and\n (azure.signinlogs.properties.risk_level_during_signin:high or azure.signinlogs.properties.risk_level_aggregated:high) and\n event.outcome:(success or Success)\n",
1717
"references": [
1818
"https://docs.microsoft.com/en-us/azure/active-directory/conditional-access/howto-conditional-access-policy-risk",
1919
"https://docs.microsoft.com/en-us/azure/active-directory/identity-protection/overview-identity-protection",
@@ -49,5 +49,5 @@
4949
],
5050
"timestamp_override": "event.ingested",
5151
"type": "query",
52-
"version": 2
52+
"version": 3
5353
}

x-pack/plugins/security_solution/server/lib/detection_engine/rules/prepackaged_rules/ml_linux_anomalous_kernel_module_arguments.json

Lines changed: 1 addition & 4 deletions
Original file line numberDiff line numberDiff line change
@@ -12,9 +12,6 @@
1212
"license": "Elastic License v2",
1313
"machine_learning_job_id": "linux_rare_kernel_module_arguments",
1414
"name": "Anomalous Kernel Module Activity",
15-
"references": [
16-
"references"
17-
],
1815
"risk_score": 21,
1916
"rule_id": "37b0816d-af40-40b4-885f-bb162b3c88a9",
2017
"severity": "low",
@@ -50,5 +47,5 @@
5047
}
5148
],
5249
"type": "machine_learning",
53-
"version": 3
50+
"version": 4
5451
}

x-pack/plugins/security_solution/server/lib/detection_engine/rules/prepackaged_rules/persistence_docker_shortcuts_plist_modification.json

Lines changed: 2 additions & 2 deletions
Original file line numberDiff line numberDiff line change
@@ -13,7 +13,7 @@
1313
"name": "Persistence via Docker Shortcut Modification",
1414
"query": "event.category : file and event.action : modification and \n file.path : /Users/*/Library/Preferences/com.apple.dock.plist and \n not process.name : (xpcproxy or cfprefsd or plutil or jamf or PlistBuddy or InstallerRemotePluginService)\n",
1515
"references": [
16-
"https://github.com/specterops/presentations/raw/master/Leo Pitt/Hey_Im_Still_in_Here_Modern_macOS_Persistence_SO-CON2020.pdf"
16+
"https://github.com/specterops/presentations/raw/master/Leo%20Pitt/Hey_Im_Still_in_Here_Modern_macOS_Persistence_SO-CON2020.pdf"
1717
],
1818
"risk_score": 47,
1919
"rule_id": "c81cefcb-82b9-4408-a533-3c3df549e62d",
@@ -44,5 +44,5 @@
4444
],
4545
"timestamp_override": "event.ingested",
4646
"type": "query",
47-
"version": 1
47+
"version": 2
4848
}

x-pack/plugins/security_solution/server/lib/detection_engine/rules/prepackaged_rules/persistence_finder_sync_plugin_pluginkit.json

Lines changed: 2 additions & 2 deletions
Original file line numberDiff line numberDiff line change
@@ -16,7 +16,7 @@
1616
"name": "Finder Sync Plugin Registered and Enabled",
1717
"query": "sequence by host.id, user.id with maxspan = 5s\n [process where event.type in (\"start\", \"process_started\") and process.name : \"pluginkit\" and process.args : \"-a\"]\n [process where event.type in (\"start\", \"process_started\") and process.name : \"pluginkit\" and\n process.args : \"-e\" and process.args : \"use\" and process.args : \"-i\" and\n not process.args :\n (\n \"com.google.GoogleDrive.FinderSyncAPIExtension\",\n \"com.google.drivefs.findersync\",\n \"com.boxcryptor.osx.Rednif\",\n \"com.adobe.accmac.ACCFinderSync\",\n \"com.microsoft.OneDrive.FinderSync\",\n \"com.insynchq.Insync.Insync-Finder-Integration\",\n \"com.box.desktop.findersyncext\"\n )\n ]\n",
1818
"references": [
19-
"https://github.com/specterops/presentations/raw/master/Leo Pitt/Hey_Im_Still_in_Here_Modern_macOS_Persistence_SO-CON2020.pdf"
19+
"https://github.com/specterops/presentations/raw/master/Leo%20Pitt/Hey_Im_Still_in_Here_Modern_macOS_Persistence_SO-CON2020.pdf"
2020
],
2121
"risk_score": 47,
2222
"rule_id": "37f638ea-909d-4f94-9248-edd21e4a9906",
@@ -46,5 +46,5 @@
4646
}
4747
],
4848
"type": "eql",
49-
"version": 1
49+
"version": 2
5050
}

x-pack/plugins/security_solution/server/lib/detection_engine/rules/prepackaged_rules/privilege_escalation_unusual_parentchild_relationship.json

Lines changed: 2 additions & 2 deletions
Original file line numberDiff line numberDiff line change
@@ -14,7 +14,7 @@
1414
"name": "Unusual Parent-Child Relationship",
1515
"query": "process where event.type in (\"start\", \"process_started\") and\nprocess.parent.name != null and\n (\n /* suspicious parent processes */\n (process.name:\"autochk.exe\" and not process.parent.name:\"smss.exe\") or\n (process.name:(\"fontdrvhost.exe\", \"dwm.exe\") and not process.parent.name:(\"wininit.exe\", \"winlogon.exe\")) or\n (process.name:(\"consent.exe\", \"RuntimeBroker.exe\", \"TiWorker.exe\") and not process.parent.name:\"svchost.exe\") or\n (process.name:\"SearchIndexer.exe\" and not process.parent.name:\"services.exe\") or\n (process.name:\"SearchProtocolHost.exe\" and not process.parent.name:(\"SearchIndexer.exe\", \"dllhost.exe\")) or\n (process.name:\"dllhost.exe\" and not process.parent.name:(\"services.exe\", \"svchost.exe\")) or\n (process.name:\"smss.exe\" and not process.parent.name:(\"System\", \"smss.exe\")) or\n (process.name:\"csrss.exe\" and not process.parent.name:(\"smss.exe\", \"svchost.exe\")) or\n (process.name:\"wininit.exe\" and not process.parent.name:\"smss.exe\") or\n (process.name:\"winlogon.exe\" and not process.parent.name:\"smss.exe\") or\n (process.name:(\"lsass.exe\", \"LsaIso.exe\") and not process.parent.name:\"wininit.exe\") or\n (process.name:\"LogonUI.exe\" and not process.parent.name:(\"wininit.exe\", \"winlogon.exe\")) or\n (process.name:\"services.exe\" and not process.parent.name:\"wininit.exe\") or\n (process.name:\"svchost.exe\" and not process.parent.name:(\"MsMpEng.exe\", \"services.exe\")) or\n (process.name:\"spoolsv.exe\" and not process.parent.name:\"services.exe\") or\n (process.name:\"taskhost.exe\" and not process.parent.name:(\"services.exe\", \"svchost.exe\")) or\n (process.name:\"taskhostw.exe\" and not process.parent.name:(\"services.exe\", \"svchost.exe\")) or\n (process.name:\"userinit.exe\" and not process.parent.name:(\"dwm.exe\", \"winlogon.exe\")) or\n (process.name:(\"wmiprvse.exe\", \"wsmprovhost.exe\", \"winrshost.exe\") and not process.parent.name:\"svchost.exe\") or\n /* suspicious child processes */\n (process.parent.name:(\"SearchProtocolHost.exe\", \"taskhost.exe\", \"csrss.exe\") and not process.name:(\"werfault.exe\", \"wermgr.exe\", \"WerFaultSecure.exe\")) or\n (process.parent.name:\"autochk.exe\" and not process.name:(\"chkdsk.exe\", \"doskey.exe\", \"WerFault.exe\")) or\n (process.parent.name:\"smss.exe\" and not process.name:(\"autochk.exe\", \"smss.exe\", \"csrss.exe\", \"wininit.exe\", \"winlogon.exe\", \"setupcl.exe\", \"WerFault.exe\")) or\n (process.parent.name:\"wermgr.exe\" and not process.name:(\"WerFaultSecure.exe\", \"wermgr.exe\", \"WerFault.exe\")) or\n (process.parent.name:\"conhost.exe\" and not process.name:(\"mscorsvw.exe\", \"wermgr.exe\", \"WerFault.exe\", \"WerFaultSecure.exe\"))\n )\n",
1616
"references": [
17-
"https://github.com/sbousseaden/Slides/blob/master/Hunting MindMaps/PNG/Windows Processes TH.map.png",
17+
"https://github.com/sbousseaden/Slides/blob/master/Hunting MindMaps/PNG/Windows Processes%20TH.map.png",
1818
"https://www.andreafortuna.org/2017/06/15/standard-windows-processes-a-brief-reference/"
1919
],
2020
"risk_score": 47,
@@ -53,5 +53,5 @@
5353
],
5454
"timestamp_override": "event.ingested",
5555
"type": "eql",
56-
"version": 8
56+
"version": 9
5757
}

0 commit comments

Comments
 (0)