Skip to content

Commit 88109b0

Browse files
author
Craig
committed
bc5 rule merge
version changes field changes to endpoint rules removed max_signals from 7 rules
1 parent 29abe5b commit 88109b0

127 files changed

Lines changed: 4314 additions & 4321 deletions

File tree

Some content is hidden

Large Commits have some content hidden by default. Use the searchbox below for content that may be hidden.
Lines changed: 23 additions & 23 deletions
Original file line numberDiff line numberDiff line change
@@ -1,24 +1,24 @@
1-
{
2-
"description": "A POST request to web application returned a 403 response, which indicates the web application declined to process the request because the action requested was not allowed",
3-
"false_positives": [
4-
"Security scans and tests may result in these errors. Misconfigured or buggy applications may produce large numbers of these errors. If the source is unexpected, the user unauthorized, or the request unusual, these may indicate suspicious or malicious activity."
5-
],
6-
"index": [
7-
"apm-*-transaction*"
8-
],
9-
"language": "kuery",
10-
"name": "Web Application Suspicious Activity: POST Request Declined",
11-
"query": "http.response.status_code:403 and http.request.method:post",
12-
"references": [
13-
"https://en.wikipedia.org/wiki/HTTP_403"
14-
],
15-
"risk_score": 47,
16-
"rule_id": "a87a4e42-1d82-44bd-b0bf-d9b7f91fb89e",
17-
"severity": "medium",
18-
"tags": [
19-
"APM",
20-
"Elastic"
21-
],
22-
"type": "query",
23-
"version": 1
1+
{
2+
"description": "A POST request to web application returned a 403 response, which indicates the web application declined to process the request because the action requested was not allowed",
3+
"false_positives": [
4+
"Security scans and tests may result in these errors. Misconfigured or buggy applications may produce large numbers of these errors. If the source is unexpected, the user unauthorized, or the request unusual, these may indicate suspicious or malicious activity."
5+
],
6+
"index": [
7+
"apm-*-transaction*"
8+
],
9+
"language": "kuery",
10+
"name": "Web Application Suspicious Activity: POST Request Declined",
11+
"query": "http.response.status_code:403 and http.request.method:post",
12+
"references": [
13+
"https://en.wikipedia.org/wiki/HTTP_403"
14+
],
15+
"risk_score": 47,
16+
"rule_id": "a87a4e42-1d82-44bd-b0bf-d9b7f91fb89e",
17+
"severity": "medium",
18+
"tags": [
19+
"APM",
20+
"Elastic"
21+
],
22+
"type": "query",
23+
"version": 2
2424
}
Lines changed: 23 additions & 23 deletions
Original file line numberDiff line numberDiff line change
@@ -1,24 +1,24 @@
1-
{
2-
"description": "A request to web application returned a 405 response which indicates the web application declined to process the request because the HTTP method is not allowed for the resource",
3-
"false_positives": [
4-
"Security scans and tests may result in these errors. Misconfigured or buggy applications may produce large numbers of these errors. If the source is unexpected, the user unauthorized, or the request unusual, these may indicate suspicious or malicious activity."
5-
],
6-
"index": [
7-
"apm-*-transaction*"
8-
],
9-
"language": "kuery",
10-
"name": "Web Application Suspicious Activity: Unauthorized Method",
11-
"query": "http.response.status_code:405",
12-
"references": [
13-
"https://en.wikipedia.org/wiki/HTTP_405"
14-
],
15-
"risk_score": 47,
16-
"rule_id": "75ee75d8-c180-481c-ba88-ee50129a6aef",
17-
"severity": "medium",
18-
"tags": [
19-
"APM",
20-
"Elastic"
21-
],
22-
"type": "query",
23-
"version": 1
1+
{
2+
"description": "A request to web application returned a 405 response which indicates the web application declined to process the request because the HTTP method is not allowed for the resource",
3+
"false_positives": [
4+
"Security scans and tests may result in these errors. Misconfigured or buggy applications may produce large numbers of these errors. If the source is unexpected, the user unauthorized, or the request unusual, these may indicate suspicious or malicious activity."
5+
],
6+
"index": [
7+
"apm-*-transaction*"
8+
],
9+
"language": "kuery",
10+
"name": "Web Application Suspicious Activity: Unauthorized Method",
11+
"query": "http.response.status_code:405",
12+
"references": [
13+
"https://en.wikipedia.org/wiki/HTTP_405"
14+
],
15+
"risk_score": 47,
16+
"rule_id": "75ee75d8-c180-481c-ba88-ee50129a6aef",
17+
"severity": "medium",
18+
"tags": [
19+
"APM",
20+
"Elastic"
21+
],
22+
"type": "query",
23+
"version": 2
2424
}
Original file line numberDiff line numberDiff line change
@@ -1,20 +1,20 @@
1-
{
2-
"description": "Elastic Endpoint detected an Adversary Behavior. Click the Elastic Endpoint icon in the event.module column or the link in the rule.reference column in the External Alerts tab of the SIEM Detections page for additional information.",
3-
"from": "now-660s",
4-
"index": [
5-
"endgame-*"
6-
],
7-
"interval": "10m",
8-
"language": "kuery",
9-
"name": "Adversary Behavior - Detected - Elastic Endpoint",
10-
"query": "event.kind:alert and event.module:endgame and event.action:rules_engine_event",
11-
"risk_score": 47,
12-
"rule_id": "77a3c3df-8ec4-4da4-b758-878f551dee69",
13-
"severity": "medium",
14-
"tags": [
15-
"Elastic",
16-
"Endpoint"
17-
],
18-
"type": "query",
19-
"version": 1
1+
{
2+
"description": "Elastic Endpoint detected an Adversary Behavior. Click the Elastic Endpoint icon in the event.module column or the link in the rule.reference column in the External Alerts tab of the SIEM Detections page for additional information.",
3+
"from": "now-660s",
4+
"index": [
5+
"endgame-*"
6+
],
7+
"interval": "10m",
8+
"language": "kuery",
9+
"name": "Adversary Behavior - Detected - Elastic Endpoint",
10+
"query": "event.kind:alert and event.module:endgame and (event.action:rules_engine_event or endgame.event_subtype_full:rules_engine_event)",
11+
"risk_score": 47,
12+
"rule_id": "77a3c3df-8ec4-4da4-b758-878f551dee69",
13+
"severity": "medium",
14+
"tags": [
15+
"Elastic",
16+
"Endpoint"
17+
],
18+
"type": "query",
19+
"version": 2
2020
}
Original file line numberDiff line numberDiff line change
@@ -1,20 +1,20 @@
1-
{
2-
"description": "Elastic Endpoint detected Credential Dumping. Click the Elastic Endpoint icon in the event.module column or the link in the rule.reference column in the External Alerts tab of the SIEM Detections page for additional information.",
3-
"from": "now-660s",
4-
"index": [
5-
"endgame-*"
6-
],
7-
"interval": "10m",
8-
"language": "kuery",
9-
"name": "Credential Dumping - Detected - Elastic Endpoint",
10-
"query": "event.kind:alert and event.module:endgame and event.action:cred_theft_event and endgame.metadata.type:detection",
11-
"risk_score": 73,
12-
"rule_id": "571afc56-5ed9-465d-a2a9-045f099f6e7e",
13-
"severity": "high",
14-
"tags": [
15-
"Elastic",
16-
"Endpoint"
17-
],
18-
"type": "query",
19-
"version": 1
1+
{
2+
"description": "Elastic Endpoint detected Credential Dumping. Click the Elastic Endpoint icon in the event.module column or the link in the rule.reference column in the External Alerts tab of the SIEM Detections page for additional information.",
3+
"from": "now-660s",
4+
"index": [
5+
"endgame-*"
6+
],
7+
"interval": "10m",
8+
"language": "kuery",
9+
"name": "Credential Dumping - Detected - Elastic Endpoint",
10+
"query": "event.kind:alert and event.module:endgame and endgame.metadata.type:detection and (event.action:cred_theft_event or endgame.event_subtype_full:cred_theft_event)",
11+
"risk_score": 73,
12+
"rule_id": "571afc56-5ed9-465d-a2a9-045f099f6e7e",
13+
"severity": "high",
14+
"tags": [
15+
"Elastic",
16+
"Endpoint"
17+
],
18+
"type": "query",
19+
"version": 2
2020
}
Original file line numberDiff line numberDiff line change
@@ -1,20 +1,20 @@
1-
{
2-
"description": "Elastic Endpoint prevented Credential Dumping. Click the Elastic Endpoint icon in the event.module column or the link in the rule.reference column in the External Alerts tab of the SIEM Detections page for additional information.",
3-
"from": "now-660s",
4-
"index": [
5-
"endgame-*"
6-
],
7-
"interval": "10m",
8-
"language": "kuery",
9-
"name": "Credential Dumping - Prevented - Elastic Endpoint",
10-
"query": "event.kind:alert and event.module:endgame and event.action:cred_theft_event and endgame.metadata.type:prevention",
11-
"risk_score": 47,
12-
"rule_id": "db8c33a8-03cd-4988-9e2c-d0a4863adb13",
13-
"severity": "medium",
14-
"tags": [
15-
"Elastic",
16-
"Endpoint"
17-
],
18-
"type": "query",
19-
"version": 1
1+
{
2+
"description": "Elastic Endpoint prevented Credential Dumping. Click the Elastic Endpoint icon in the event.module column or the link in the rule.reference column in the External Alerts tab of the SIEM Detections page for additional information.",
3+
"from": "now-660s",
4+
"index": [
5+
"endgame-*"
6+
],
7+
"interval": "10m",
8+
"language": "kuery",
9+
"name": "Credential Dumping - Prevented - Elastic Endpoint",
10+
"query": "event.kind:alert and event.module:endgame and endgame.metadata.type:prevention and (event.action:cred_theft_event or endgame.event_subtype_full:cred_theft_event)",
11+
"risk_score": 47,
12+
"rule_id": "db8c33a8-03cd-4988-9e2c-d0a4863adb13",
13+
"severity": "medium",
14+
"tags": [
15+
"Elastic",
16+
"Endpoint"
17+
],
18+
"type": "query",
19+
"version": 2
2020
}
Original file line numberDiff line numberDiff line change
@@ -1,20 +1,20 @@
1-
{
2-
"description": "Elastic Endpoint detected Credential Manipulation. Click the Elastic Endpoint icon in the event.module column or the link in the rule.reference column in the External Alerts tab of the SIEM Detections page for additional information.",
3-
"from": "now-660s",
4-
"index": [
5-
"endgame-*"
6-
],
7-
"interval": "10m",
8-
"language": "kuery",
9-
"name": "Credential Manipulation - Detected - Elastic Endpoint",
10-
"query": "event.kind:alert and event.module:endgame and event.action:token_manipulation_event and endgame.metadata.type:detection",
11-
"risk_score": 73,
12-
"rule_id": "c0be5f31-e180-48ed-aa08-96b36899d48f",
13-
"severity": "high",
14-
"tags": [
15-
"Elastic",
16-
"Endpoint"
17-
],
18-
"type": "query",
19-
"version": 1
1+
{
2+
"description": "Elastic Endpoint detected Credential Manipulation. Click the Elastic Endpoint icon in the event.module column or the link in the rule.reference column in the External Alerts tab of the SIEM Detections page for additional information.",
3+
"from": "now-660s",
4+
"index": [
5+
"endgame-*"
6+
],
7+
"interval": "10m",
8+
"language": "kuery",
9+
"name": "Credential Manipulation - Detected - Elastic Endpoint",
10+
"query": "event.kind:alert and event.module:endgame and endgame.metadata.type:detection and (event.action:token_manipulation_event or endgame.event_subtype_full:token_manipulation_event)",
11+
"risk_score": 73,
12+
"rule_id": "c0be5f31-e180-48ed-aa08-96b36899d48f",
13+
"severity": "high",
14+
"tags": [
15+
"Elastic",
16+
"Endpoint"
17+
],
18+
"type": "query",
19+
"version": 2
2020
}
Original file line numberDiff line numberDiff line change
@@ -1,20 +1,20 @@
1-
{
2-
"description": "Elastic Endpoint prevented Credential Manipulation. Click the Elastic Endpoint icon in the event.module column or the link in the rule.reference column in the External Alerts tab of the SIEM Detections page for additional information.",
3-
"from": "now-660s",
4-
"index": [
5-
"endgame-*"
6-
],
7-
"interval": "10m",
8-
"language": "kuery",
9-
"name": "Credential Manipulation - Prevented - Elastic Endpoint",
10-
"query": "event.kind:alert and event.module:endgame and event.action:token_manipulation_event and endgame.metadata.type:prevention",
11-
"risk_score": 47,
12-
"rule_id": "c9e38e64-3f4c-4bf3-ad48-0e61a60ea1fa",
13-
"severity": "medium",
14-
"tags": [
15-
"Elastic",
16-
"Endpoint"
17-
],
18-
"type": "query",
19-
"version": 1
1+
{
2+
"description": "Elastic Endpoint prevented Credential Manipulation. Click the Elastic Endpoint icon in the event.module column or the link in the rule.reference column in the External Alerts tab of the SIEM Detections page for additional information.",
3+
"from": "now-660s",
4+
"index": [
5+
"endgame-*"
6+
],
7+
"interval": "10m",
8+
"language": "kuery",
9+
"name": "Credential Manipulation - Prevented - Elastic Endpoint",
10+
"query": "event.kind:alert and event.module:endgame and endgame.metadata.type:prevention and (event.action:token_manipulation_event or endgame.event_subtype_full:token_manipulation_event)",
11+
"risk_score": 47,
12+
"rule_id": "c9e38e64-3f4c-4bf3-ad48-0e61a60ea1fa",
13+
"severity": "medium",
14+
"tags": [
15+
"Elastic",
16+
"Endpoint"
17+
],
18+
"type": "query",
19+
"version": 2
2020
}
Lines changed: 19 additions & 19 deletions
Original file line numberDiff line numberDiff line change
@@ -1,20 +1,20 @@
1-
{
2-
"description": "Elastic Endpoint detected an Exploit. Click the Elastic Endpoint icon in the event.module column or the link in the rule.reference column in the External Alerts tab of the SIEM Detections page for additional information.",
3-
"from": "now-660s",
4-
"index": [
5-
"endgame-*"
6-
],
7-
"interval": "10m",
8-
"language": "kuery",
9-
"name": "Exploit - Detected - Elastic Endpoint",
10-
"query": "event.kind:alert and event.module:endgame and event.action:exploit_event and endgame.metadata.type:detection",
11-
"risk_score": 73,
12-
"rule_id": "2003cdc8-8d83-4aa5-b132-1f9a8eb48514",
13-
"severity": "high",
14-
"tags": [
15-
"Elastic",
16-
"Endpoint"
17-
],
18-
"type": "query",
19-
"version": 1
1+
{
2+
"description": "Elastic Endpoint detected an Exploit. Click the Elastic Endpoint icon in the event.module column or the link in the rule.reference column in the External Alerts tab of the SIEM Detections page for additional information.",
3+
"from": "now-660s",
4+
"index": [
5+
"endgame-*"
6+
],
7+
"interval": "10m",
8+
"language": "kuery",
9+
"name": "Exploit - Detected - Elastic Endpoint",
10+
"query": "event.kind:alert and event.module:endgame and endgame.metadata.type:detection and (event.action:exploit_event or endgame.event_subtype_full:exploit_event)",
11+
"risk_score": 73,
12+
"rule_id": "2003cdc8-8d83-4aa5-b132-1f9a8eb48514",
13+
"severity": "high",
14+
"tags": [
15+
"Elastic",
16+
"Endpoint"
17+
],
18+
"type": "query",
19+
"version": 2
2020
}
Original file line numberDiff line numberDiff line change
@@ -1,20 +1,20 @@
1-
{
2-
"description": "Elastic Endpoint prevented an Exploit. Click the Elastic Endpoint icon in the event.module column or the link in the rule.reference column in the External Alerts tab of the SIEM Detections page for additional information.",
3-
"from": "now-660s",
4-
"index": [
5-
"endgame-*"
6-
],
7-
"interval": "10m",
8-
"language": "kuery",
9-
"name": "Exploit - Prevented - Elastic Endpoint",
10-
"query": "event.kind:alert and event.module:endgame and event.action:exploit_event and endgame.metadata.type:prevention",
11-
"risk_score": 47,
12-
"rule_id": "2863ffeb-bf77-44dd-b7a5-93ef94b72036",
13-
"severity": "medium",
14-
"tags": [
15-
"Elastic",
16-
"Endpoint"
17-
],
18-
"type": "query",
19-
"version": 1
1+
{
2+
"description": "Elastic Endpoint prevented an Exploit. Click the Elastic Endpoint icon in the event.module column or the link in the rule.reference column in the External Alerts tab of the SIEM Detections page for additional information.",
3+
"from": "now-660s",
4+
"index": [
5+
"endgame-*"
6+
],
7+
"interval": "10m",
8+
"language": "kuery",
9+
"name": "Exploit - Prevented - Elastic Endpoint",
10+
"query": "event.kind:alert and event.module:endgame and endgame.metadata.type:prevention and (event.action:exploit_event or endgame.event_subtype_full:exploit_event)",
11+
"risk_score": 47,
12+
"rule_id": "2863ffeb-bf77-44dd-b7a5-93ef94b72036",
13+
"severity": "medium",
14+
"tags": [
15+
"Elastic",
16+
"Endpoint"
17+
],
18+
"type": "query",
19+
"version": 2
2020
}

0 commit comments

Comments
 (0)