Skip to content

Commit b5db6a7

Browse files
committed
Use event.timezone in all date processors
1 parent ea31de1 commit b5db6a7

File tree

3 files changed

+14
-1
lines changed

3 files changed

+14
-1
lines changed

packages/auditd/changelog.yml

Lines changed: 3 additions & 0 deletions
Original file line numberDiff line numberDiff line change
@@ -4,6 +4,9 @@
44
- description: make GA
55
type: enhancement
66
link: https://github.com/elastic/integrations/pull/1215
7+
- description: Set "event.module" and "event.dataset"
8+
type: enhancement
9+
link: https://github.com/elastic/integrations/pull/1215
710
- version: "0.2.0"
811
changes:
912
- description: update to ECS 1.10.0 and apply changes to prepare for package GA

packages/auditd/data_stream/log/fields/base-fields.yml

Lines changed: 8 additions & 0 deletions
Original file line numberDiff line numberDiff line change
@@ -7,6 +7,14 @@
77
- name: data_stream.namespace
88
type: constant_keyword
99
description: Data stream namespace.
10+
- name: event.module
11+
type: constant_keyword
12+
description: Event module
13+
value: auditd
14+
- name: event.dataset
15+
type: constant_keyword
16+
description: Event dataset
17+
value: auditd.log
1018
- name: '@timestamp'
1119
type: date
1220
description: Event timestamp.

packages/auditd/docs/README.md

Lines changed: 3 additions & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -155,7 +155,9 @@ An example event for `log` looks as following:
155155
| ecs.version | ECS version | keyword |
156156
| error.message | Error message. | text |
157157
| event.action | The action captured by the event. This describes the information in the event. It is more specific than `event.category`. Examples are `group-add`, `process-started`, `file-created`. The value is normally defined by the implementer. | keyword |
158+
| event.dataset | Event dataset | constant_keyword |
158159
| event.ingested | Timestamp when an event arrived in the central data store. This is different from `@timestamp`, which is when the event originally occurred. It's also different from `event.created`, which is meant to capture the first time an agent saw the event. In normal conditions, assuming no tampering, the timestamps should chronologically look like this: `@timestamp` < `event.created` < `event.ingested`. | date |
160+
| event.module | Event module | constant_keyword |
159161
| event.outcome | This is one of four ECS Categorization Fields, and indicates the lowest level in the ECS category hierarchy. `event.outcome` simply denotes whether the event represents a success or a failure from the perspective of the entity that produced the event. Note that when a single transaction is described in multiple events, each event may populate different values of `event.outcome`, according to their perspective. Also note that in the case of a compound event (a single event that contains multiple logical events), this field should be populated with the value that best captures the overall success or failure from the perspective of the event producer. Further note that not all events will have an associated outcome. For example, this field is generally not populated for metric events, events with `event.type:info`, or any events for which an outcome does not make logical sense. | keyword |
160162
| group.id | Unique identifier for the group on the system/platform. | keyword |
161163
| group.name | Name of the group. | keyword |
@@ -206,7 +208,7 @@ An example event for `log` looks as following:
206208
| user.audit.name | Short name or login of the user. | keyword |
207209
| user.effective.group.id | Unique identifier for the group on the system/platform. | keyword |
208210
| user.effective.group.name | Name of the group. | keyword |
209-
| user.effective.id | One or multiple unique identifiers of the user. | keyword |
211+
| user.effective.id | Unique identifier of the user. | keyword |
210212
| user.effective.name | Short name or login of the user. | keyword |
211213
| user.filesystem.group.id | Unique identifier for the group on the system/platform. | keyword |
212214
| user.filesystem.group.name | Name of the group. | keyword |

0 commit comments

Comments
 (0)