File tree Expand file tree Collapse file tree 3 files changed +13
-0
lines changed
data_stream/system/fields Expand file tree Collapse file tree 3 files changed +13
-0
lines changed Original file line number Diff line number Diff line change 44 - description : make GA
55 type : enhancement
66 link : https://github.com/elastic/integrations/pull/1222
7+ - description : Set "event.module" and "event.dataset"
8+ type : enhancement
9+ link : https://github.com/elastic/integrations/pull/1222
710- version : " 0.6.0"
811 changes :
912 - description : Update to ECS 1.10.0 and add event.original options
Original file line number Diff line number Diff line change 77- name : data_stream.namespace
88 type : constant_keyword
99 description : Data stream namespace.
10+ - name : event.module
11+ type : constant_keyword
12+ description : Event module
13+ value : okta
14+ - name : event.dataset
15+ type : constant_keyword
16+ description : Event dataset
17+ value : okta.system
1018- name : " @timestamp"
1119 type : date
1220 description : Event timestamp.
Original file line number Diff line number Diff line change @@ -217,9 +217,11 @@ An example event for `system` looks as following:
217217| error.message | Error message. | text |
218218| event.action | The action captured by the event. | keyword |
219219| event.category | Event category. The second categorization field in the hierarchy. | keyword |
220+ | event.dataset | Event dataset | constant_keyword |
220221| event.id | Unique ID to describe the event. | keyword |
221222| event.ingested | Timestamp when an event arrived in the central data store. | date |
222223| event.kind | The kind of the event. The highest categorization field in the hierarchy. | keyword |
224+ | event.module | Event module | constant_keyword |
223225| event.original | Raw text message of entire event. | keyword |
224226| event.outcome | The outcome of the event. The lowest level categorization field in the hierarchy. | keyword |
225227| event.type | Event type. The third categorization field in the hierarchy. | keyword |
You can’t perform that action at this time.
0 commit comments